Changes

Jump to navigation Jump to search
no edit summary
Line 1: Line 1: −
== Prerequisites ==
+
[[Category:Tools]]
Ensure you have a '''64 bit version''' of Python 3.'''6+''' before continuing. You will not be able to install or launch EventEditor otherwise.
+
[[Category:Tools (BFEVFL)]]
 +
{{Tool infobox
 +
| name = EventEditor
 +
| authors = leoetlino
 +
| source = https://github.com/leoetlino/event-editor
 +
| license = GPLv3
 +
| written_in = Python
 +
| win_only =
 +
}}
   −
Older versions of Windows such as Windows 7 are not recommended because of incompatibilities in the Qt library; you may need to manually install an older version of PyQt5 if you are on an old OS.
+
== Setup ==
 
+
# Ensure you have a '''64 bit version''' of Python 3.'''6+''' before continuing. You will not be able to install or launch EventEditor otherwise.
== Installing ==
   
# Install PyQt5.
 
# Install PyQt5.
 
#* If you're on Linux, use your package manager. The package for Debian is called <code>python3-pyqt5</code>. You will also need to install <code>python3-pyqt5.qtwebengine</code>.
 
#* If you're on Linux, use your package manager. The package for Debian is called <code>python3-pyqt5</code>. You will also need to install <code>python3-pyqt5.qtwebengine</code>.
Line 30: Line 37:  
* On Linux or macOS: at <code>~/.config/eventeditor/eventeditor.ini</code>
 
* On Linux or macOS: at <code>~/.config/eventeditor/eventeditor.ini</code>
 
* On Windows: at <code>%APPDATA%/eventeditor/eventeditor.ini</code>
 
* On Windows: at <code>%APPDATA%/eventeditor/eventeditor.ini</code>
  −
[[Category: Guides]]
  −
[[Category: Guides (tools)]]
 
Anonymous user

Navigation menu